Database Incident - Resolved

Incident Report for Dotcom Monitor

Resolved

Post-Incident Summary: August 11, 2025
Incident window: 11:35 AM–12:10 PM CDT (35 minutes)
Engagement: 11:40 AM CDT
RTO (Recovery Time Objective): 60 minutes
Outcome: Met — service fully restored in 35 minutes
What happened
A database counter reached its limit, which temporarily blocked new records and caused errors for some customers. Monitoring was unavailable during the window.
What we did
• Began troubleshooting within 5 minutes of impact.
• Identified the database limit issue and restored normal operations by 12:10 PM.
• Implemented a permanent fix to expand capacity and prevent recurrence.
• Added earlier alerts and guardrails to catch similar issues well before they affect customers.
Timeline (CDT)
• 11:35 AM – Service degradation begins.
• 11:40 AM – Team engaged and triaged.
• 12:10 PM – Full recovery confirmed.
Customer impact
No action is required from customers. All systems are operating normally.
Our commitment
We know downtime is disruptive. We’ve strengthened safeguards to reduce the chance and impact of similar issues going forward. If you have questions, please contact your account manager or Support.
Posted Aug 11, 2025 - 11:35 CDT