Madrid, Spain Location Down

Incident Report for Dotcom Monitor

Resolved

Madrid, Spain monitoring location is available for monitoring
Posted Sep 04, 2025 - 23:59 CDT

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 23:58 CDT

Investigating

Madrid, Spain monitoring location is not available for monitoring due to ISP outage. We'll provide an update as soon as we have any.
Posted Sep 04, 2025 - 22:46 CDT
This incident affected: Monitoring.