Madrid, Spain Monitoring Location Down

Incident Report for Dotcom Monitor

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 03:12 CST

Identified

Madrid, Spain Monitoring Location is currently offline due to host hardware issue. Our team is working on the resolution.
Posted Feb 09, 2026 - 15:20 CST
This incident affected: Monitoring Locations.