Madrid, Spain Location Down

Incident Report for Dotcom Monitor

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 21:52 CDT

Identified

Madrid, Spain monitoring location is not available for monitoring due to power outage. We'll provide an update as soon as we have any.
Posted Apr 28, 2025 - 11:54 CDT
This incident affected: Monitoring Locations.