The issue has been resolved, and all of the services should be operational.
Posted Oct 10, 2025 - 05:35 CDT
Update
2025-10-10 09:11:25 GMT - On October 10, 2025, at 09:00 GMT, Lumen discovered a service impact in Minneapolis, MN. Your customer trouble ticket has been related to a network event; all network events are automatically escalated to Lumen leadership. The Lumen Network Operations Center (NOC) is investigating to determine the cause. Please be advised that live updates for this event will be relayed at a minimum of hourly unless otherwise stated or as relevant details evolve.
Posted Oct 10, 2025 - 04:41 CDT
Investigating
Currently our datacenter at the Minneapolis is experiencing network degradation due to the outage at the backbone provider. Certain sites checks may return errors from the MN location, also some of our monitoring locations (Denver, Montreal, San Francisco) may also have missed checks due to communication disruptions. This also may affect some Load testing regions.
Posted Oct 10, 2025 - 04:41 CDT
This incident affected: Monitoring, Load Testing, and Monitoring Locations.